PDA

View Full Version : version 612 and 615



M.YasPro
دوشنبه 24 اسفند 1388, 09:22 صبح
سلام
من میخوام یه دیتابیس رو تو visual studio اتچ کنم ولی ارور میده و میگه که این فایل دیتابیس برای version 655 هست و sqlexpress ی که تو vs هست این رو ساپورت نمی کنه
متن ارور :


cannot be opened because it is version 655. This server supports version 612 and earlier. A downgrade path is not supported.


من رو سیستم sql2008 دارم و دیتابیسم رو با اون ساختم ولی زمان ساخت Compatibility رو روی
2005 گذاشتم .

ممنون از توجهتون .

AminSobati
دوشنبه 24 اسفند 1388, 10:15 صبح
سلام دوست عزیزم،
Compatibility Level ارتباطی با این مشکل نداره. وقتی دیتابیس در یک ورژن کار میکنه، نمیشه به ورژن پایین تر برد. Compatibility Level تاثیرش روی رفتار بعضی از دستورات دیده میشه

M.YasPro
دوشنبه 24 اسفند 1388, 10:39 صبح
تشکر از توجهتون
راهی رو به من پیشنهاد نکردین !
به جز دوباره ساختن دیتابیس در 2005