PDA

View Full Version : فارسی نویسی در دلفی 7



tazekar
دوشنبه 07 مهر 1382, 20:27 عصر
سلام
چکار کنم تا دلفی 7 توی ویندوز 2000 با فارسی نویسی مشکلی نداشته باشه ؟

saeed_d
سه شنبه 08 مهر 1382, 14:29 عصر
دوست عزیز
اگر ممکنه در مورد مشکلت بیشتر توضیح بده :o

tazekar
سه شنبه 08 مهر 1382, 19:25 عصر
سلام
راستش تمام حروف فارسی رو نامفهوم مینویسه .
از کپشن خود فرم گرفته تا باتونها .
در ضمن ویندوز من هم 2000 سرور هستش .
با یونیکد هم امتحان کردم بازم نشد .
ممنون میشم اگه کمکم کنید . :wink:

SyntaxCheck
پنج شنبه 10 مهر 1382, 06:05 صبح
http://www.barnamenevis.org/forum/viewtopic.php?p=12800&highlight=#12800

tazekar
پنج شنبه 10 مهر 1382, 10:55 صبح
سلام
جناب SyntaxCheck عزیز من اوون مطلب رو قبلا خوندم .
اما مشکل من اینه که ویندوزم 2000 سرور هستش.
در این مورد اگه کمکم کنید ممنون میشم . :oops:

Hidarneh
پنج شنبه 10 مهر 1382, 22:33 عصر
منم همین سیستم رو دارم . ولی بدون مشگل تو راجع به سیستمت بگو . ( مشخصات سیستم ) و اینکه اگه سرویس پکها رو نصب کنی احتمال زیاد مشگلت حل می شه .

tazekar
پنج شنبه 10 مهر 1382, 23:56 عصر
سلام
منم توی ویندوز xp مشکلی ندارم اما توی 2000 سرور این مشکل برام پیش میاد :!:
Hidarneh عزیز چه سرویس پکهایی رو باید نسب کنم ؟

SRNOURI
جمعه 02 آبان 1382, 01:40 صبح
دوستان سلام
منهم این مشکل رو در ویندوز XP profesional دارم و در دلفی 7 نمیتونم فارسی بنویسم اگه ممکنه منو هم راهنمایی کنید.
مخلص همه بچه های دلفی کار :? :o

N_D
جمعه 02 آبان 1382, 22:10 عصر
دوستان من هم این مشکل رو داشتم . ولی با چونه زدن حلش کردم
در winxp اگر در ابتدای مرحله نصب فارسی را انتخاب نکرده و همچنین گزینه پشتیبانی زبانهای چپ به راست را انتخاب نکرده باشید این مشکل بوجود می آید.

جناب tazekar با عرض سلام . باید بگم من هم ویندوز 2000 سرور دارم که مشکل شما رو داشت این مشکل زمانی اتفاق می افتد که از طریق DOS سیستم عامل را نصب کرده باشید که در این حالت زبان فارسی جزئ آمار win2k نیست :( ولی اگر از طریق win98 عربی win2000 adv server را نصب کنید مشکل شما حل می شود فقط در اوایل نصب حتما آنرا روی زبان فارسی تنظیم کنید .
اما در وضعیت کنونی شما ابتدا روال ذکر شده توسط sysntaxcheck رو دنبال کنید اگر حل نشد مراحل زیر را دنبال کنید.(و هر بار log off کنید)
1- ابتدا زبان arabic را add کنید و تست کنید که مشکل حل شده یا نه.
2- در حالت safe mode سیتم را بالا آورده و kbdfa.dll را پاک کنید . در این حالت از طریق صحیح و خطا چند بار زبان arabic را حذف و مجددا اضافه کنید. با چند بار حذف و اضافه و پاک کردن آثار فارسی نهایتا خود سیستم از دست شما کلافه شده و فارسی را به شما هدیه می کند .
باز هم توصیه میکنم با سیستم در قسمت حذف و اضافه زبانها چونه بزنید :lol:

tazekar
شنبه 03 آبان 1382, 08:31 صبح
:D

FDavood
سه شنبه 20 آبان 1382, 08:10 صبح
برو داخل کنترل Control panel / reginal setting

یه کلید Set default میبینی . اونجا فارسی رو انتخاب کن. سیستم رو ری استارت کن!

مخلصم
داود

mostafa612003
شنبه 24 آبان 1382, 10:49 صبح
سلام
من در ویندوز 2000 کارمی کنم تنظیمات مربوط به فارسی کردن ویندوز را نیز انجام دادم
در محیطهای دیگر با فارسی نوشتن مشکلی ندارم ولی در دلفی نمی توانم فارسی بنویسم

متشکرم

B-Vedadian
دوشنبه 26 آبان 1382, 10:46 صبح
سلام

من یک مشکل جالب بگم. اگه ابتدایی بود لطفاً نخندید! :oops:

من در XP برنامه فارسی رو که رو 98 نوشته بودم امتحان کردم، نوشته ها رو فارسی مینویسه حتی توی دلفی 7 هم مشکلی نیست اما فونت رو روی کپشن فرم داغون می کنه. یعنی نوشته ها ریز و ناجور دیده میشن. فونت کپشن ها رو هم تغییر دادم ( توی Display Settings) اما کاری از پیش نبردم.

لطفاْ این مشکل رو هم در نظر بگیرید.