نمایش نتایج 1 تا 3 از 3

نام تاپیک: خطا موقع آپدیت Gradle

  1. #1

    Question خطا موقع آپدیت Gradle

    سلام وقت بخیر..
    من یه پروژه با اندروید استودیو میخوام اجرا کنم، یه خطا میده.هرچیم فیلتر شکن اجرا میکنم برای آپدیتش فایده نداره..
    Error:Unable to find method 'com.android.build.gradle.tasks.factory.AndroidJav aCompile.setDependencyCacheDir(Ljava/io/File;)V'.
    Possible causes for this unexpected error include:<ul><li>Gradle's dependency cache may be corrupt (this sometimes occurs after a network connection timeout.)
    <a href="syncProject">Re-download dependencies and sync project (requires network)</a></li><li>The state of a Gradle build process (daemon) may be corrupt. Stopping all Gradle daemons may solve this problem.
    <a href="stopGradleDaemons">Stop Gradle build processes (requires restart)</a></li><li>Your project may be using a third-party plugin which is not compatible with the other plugins in the project or the version of Gradle requested by the project.</li></ul>In the case of corrupt Gradle processes, you can also try closing the IDE and then killing all Java processes.

    کسی میدونه دلیلش چیه؟Screenshot (34).jpg

  2. #2
    کاربر جدید آواتار soltanMohammad
    تاریخ عضویت
    آذر 1398
    محل زندگی
    تهران
    سن
    29
    پست
    2

    نقل قول: خطا موقع آپدیت Gradle

    سلام
    چرا اسکرین شات از صفحه اکتیویتی دادی؟!
    محتویات فایل app/build.gradle رو بده ببینیم
    به نظرم اول یه پروژه خالی ایجاد کن و ببین سینک میشه یا نه

  3. #3

    نقل قول: خطا موقع آپدیت Gradle

    نقل قول نوشته شده توسط soltanMohammad مشاهده تاپیک
    سلام
    چرا اسکرین شات از صفحه اکتیویتی دادی؟!
    محتویات فایل app/build.gradle رو بده ببینیم
    به نظرم اول یه پروژه خالی ایجاد کن و ببین سینک میشه یا نه
    سلام.من الان دیدم جواب دادید
    هنوز مشکلم حل نشده.پروژه خالی سینک میشه.
    اینم محتویات گردل:

    apply plugin: 'com.android.application'

    /*allprojects {
    repositories {
    jcenter()
    maven {
    url "https://maven.google.com"
    }
    }
    }*/

    android {
    compileSdkVersion 27
    buildToolsVersion '27.0.2'
    defaultConfig {
    applicationId "***"
    minSdkVersion 15
    targetSdkVersion 27
    versionCode 7
    versionName "1.7"
    multiDexEnabled true
    vectorDrawables.useSupportLibrary = true
    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunne r"
    }
    buildTypes {
    release {
    minifyEnabled false
    proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
    }

    lintOptions {

    checkReleaseBuilds false

    }
    compileOptions {
    sourceCompatibility = JavaVersion.VERSION_1_7
    targetCompatibility = JavaVersion.VERSION_1_7
    }

    useLibrary 'org.apache.http.legacy'

    }


    configurations {
    all {
    exclude module: 'httpclient'
    }
    }

    dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    //implementation fileTree(include: ['*.jar'], dir: 'libs')
    //noinspection GradleCompatible
    compile 'com.android.support:appcompat-v7:27.0.2'
    compile 'com.android.support:design:27.0.2'
    compile 'com.android.support:support-v4:27.0.2'
    compile 'com.android.support:recyclerview-v7:27.0.2'
    compile 'com.android.support.constraint:constraint-layout:1.0.2'
    compile 'com.jakewharton:butterknife:8.8.1'
    compile 'com.jakewharton:butterknife-compiler:8.8.1'
    compile 'com.iarcuschin:simpleratingbar:0.1.5'
    compile 'de.hdodenhof:circleimageview:2.2.0'
    compile 'com.google.code.gson:gson:2.8.2'
    compile 'com.squareup.picasso:picasso:2.5.2'
    compile 'com.pnikosis:materialish-progress:1.7'
    compile 'org.scribe:scribe:1.3.5'
    compile 'com.github.bumptech.glide:glide:3.7.0'
    compile 'com.facebook.android:facebook-login:[4,5)'
    // implementation 'com.google.firebase:firebase-auth:11.8.0'
    // implementation 'com.google.android.gms:play-services-auth:11.8.0'
    // implementation 'com.google.firebase:firebase-messaging:11.8.0'
    // implementation 'com.google.firebase:firebase-crash:11.8.0'
    // implementation 'com.google.android.gms:play-services-location:11.8.0'
    // implementation 'com.google.android.gms:play-services-ads:11.8.0'
    // implementation 'com.google.android.gms:play-services:11.8.0'
    compile 'com.android.support:multidex:1.0.1'
    compile 'org.sufficientlysecure:html-textview:3.5'
    compile 'co.ronash.android:pushe-base:1.4.3'
    // implementation 'com.android.volley:volley:1.1.0'
    }
    //apply plugin: 'com.google.gms.google-services'
    آخرین ویرایش به وسیله تبسم ساینا : سه شنبه 03 دی 1398 در 10:20 صبح

تاپیک های مشابه

  1. مشکل با gradle
    نوشته شده توسط olampiad در بخش Android Studio
    پاسخ: 3
    آخرین پست: سه شنبه 05 اردیبهشت 1396, 01:22 صبح
  2. ارور gradle
    نوشته شده توسط Aram0630 در بخش Android Studio
    پاسخ: 0
    آخرین پست: سه شنبه 11 آبان 1395, 12:35 عصر
  3. زمان طولانی ساخت gradle
    نوشته شده توسط shahin bahari در بخش Android Studio
    پاسخ: 3
    آخرین پست: دوشنبه 08 شهریور 1395, 04:18 صبح
  4. مشکل با اضافه کردن کتابخانه به Gradle
    نوشته شده توسط nasr در بخش Android Studio
    پاسخ: 8
    آخرین پست: چهارشنبه 03 شهریور 1395, 11:56 صبح
  5. مشکل با gradle
    نوشته شده توسط sonicuser در بخش Android Studio
    پاسخ: 5
    آخرین پست: یک شنبه 25 بهمن 1394, 14:19 عصر

قوانین ایجاد تاپیک در تالار

  • شما نمی توانید تاپیک جدید ایجاد کنید
  • شما نمی توانید به تاپیک ها پاسخ دهید
  • شما نمی توانید ضمیمه ارسال کنید
  • شما نمی توانید پاسخ هایتان را ویرایش کنید
  •