نمایش نتایج 1 تا 4 از 4

نام تاپیک: عدم اجرای npm run dev

  1. #1
    کاربر دائمی آواتار pary_daryayi
    تاریخ عضویت
    آذر 1391
    محل زندگی
    گرگان
    پست
    371

    عدم اجرای npm run dev

    سلام دوستان . وقتی کد npm run dev رو اجرا میکنم کلی خطا میده .
    مشابه سوال و خطاهای داده شده برای من تو این لینک اومده . با اینکه مراحل پیشنهادی رو انجام میدم اما نتیجه نمیگیرم .


    https://stackoverflow.com/questions/...un-npm-run-dev

    این هم اطلاعات composer.json من :






    "name": "laravel/laravel",
    "type": "project",
    "description": "The Laravel Framework.",
    "keywords": [
    "framework",
    "laravel"
    ],
    "license": "MIT",
    "require": {
    "php": "^7.2.5|^8.0",
    "fideloper/proxy": "^4.4",
    "fruitcake/laravel-cors": "^2.0",
    "guzzlehttp/guzzle": "^6.3.1|^7.0.1",
    "laravel/framework": "^7.29",
    "laravel/tinker": "^2.5",
    "laravel/ui": "2.4"
    },
    "require-dev": {
    "facade/ignition": "^2.0",
    "fakerphp/faker": "^1.9.1",
    "mockery/mockery": "^1.3.1",
    "nunomaduro/collision": "^4.3",
    "phpunit/phpunit": "^8.5.8|^9.3.3"
    },
    "config": {
    "optimize-autoloader": true,
    "preferred-install": "dist",
    "sort-packages": true
    },
    "extra": {
    "laravel": {
    "dont-discover": []
    }
    },
    "autoload": {
    "psr-4": {
    "App\\": "app/"
    },
    "classmap": [
    "database/seeds",
    "database/factories"
    ]
    },
    "autoload-dev": {
    "psr-4": {
    "Tests\\": "tests/"
    }
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "scripts": {
    "post-autoload-dump": [
    "Illuminate\\Foundation\\ComposerScripts::postAuto loadDump",
    "@php artisan package:discover --ansi"
    ],
    "post-root-package-install": [
    "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
    ],
    "post-create-project-cmd": [
    "@php artisan key:generate --ansi"
    ]
    }
    }









  2. #2
    کاربر دائمی آواتار plague
    تاریخ عضویت
    آبان 1388
    محل زندگی
    اهواز
    پست
    2,357

    نقل قول: عدم اجرای npm run dev

    composer و npm اصطلاحا package/dependency manager هستن کارشون اینه که کتابخونه هایی که نیازه تو پروژه داشته باشی رو نصب و اجرا میکنن
    لیست این کتابخونه ها توی یک فایل json هست که شما وقتی دستور رو میزنی از این فایل لیست رو میخونه دانلود و اجرا میکنه


    composer برای کتابخونه های php هست که تو پروژت داری وبا فایل composer.json کار میکنه و فایل های دانلودی رو تو فولدر vendor دانلود میکنه

    npm برای کتابخونه های javascript هستش که نصب و اجراشون میکنه و با فایل package.json کار میکنه و ربطی به فایل composer.json نداره

    تو فایل package.json قسمت scripts یه سری دستور هست که وقتی بزنی npm run اونهارو اجرا میکنه

    اینکه چرا ارررو میده ممکنه دلایل مختلفی داشته باشه باید اون متن اررور رو خوند ولی احتمالا کتابخونه ها رو نصب نکردی و میخای اجراشون کنی که اررو میده
    باید اول بزنی npm install یک فولدر ساخته میشه به اسم node_modules که این کتابخونه های مورد نیاز دانلود میشن و توش قرار داده میشن و بعد میتونی اجراشون کنی

  3. #3
    کاربر دائمی آواتار pary_daryayi
    تاریخ عضویت
    آذر 1391
    محل زندگی
    گرگان
    پست
    371

    نقل قول: عدم اجرای npm run dev

    پوشه ی node_modules ساخته شده بود از قبل .
    و پکیج هایی نصب هست .
    ولی وقتی nmp run dev رو میزنم این خطاها رو میده :



    > @ development C:\xampp\htdocs\mysite\ecommer
    > cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --config=node_modules/laravel-mix/setup/webpack.config.js


    'cross-env' is not recognized as an internal or external command,
    operable program or batch file.
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! @ development: `cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --config=node_modules/laravel-mix/setup/webp
    ack.config.js`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the @ development script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.


    npm ERR! A complete log of this run can be found in:
    npm ERR! C:\Users\MDR 32322170\AppData\Roaming\npm-cache\_logs\2022-05-17T05_01_09_159Z-debug.log
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! @ dev: `npm run development`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the @ dev script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.


    npm ERR! A complete log of this run can be found in:
    npm ERR! C:\Users\MDR 32322170\AppData\Roaming\npm-cache\_logs\2022-05-17T05_01_09_302Z-debug.log





    webpack , cross-env هم نصب هستن :
    package.json :


    {
    "private": true,
    "scripts": {
    "dev": "npm run development",
    "development": "cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --config=node_modules/laravel-mix/setup/webpack.config.js",
    "watch": "npm run development -- --watch",
    "watch-poll": "npm run watch -- --watch-poll",
    "hot": "cross-env NODE_ENV=development node_modules/webpack-dev-server/bin/webpack-dev-server.js --inline --hot --disable-host-check --config=node_modules/laravel-mix/setup/webpack.config.js",
    "prod": "npm run production",
    "production": "cross-env NODE_ENV=production node_modules/webpack/bin/webpack.js --no-progress --config=node_modules/laravel-mix/setup/webpack.config.js"
    },
    "devDependencies": {
    "axios": "^0.27.2",
    "bootstrap": "^4.6.1",
    "cross-env": "^7.0",
    "jquery": "^3.2",
    "laravel-mix": "^6.0.43",
    "lodash": "^4.17.19",
    "popper.js": "^1.12",
    "resolve-url-loader": "^3.1.0",
    "sass": "^1.51.0",
    "sass-loader": "^8.0.0",
    "webpack": "^5.72.0",
    "webpack-command": "^0.5.1"
    }
    }
    آخرین ویرایش به وسیله pary_daryayi : سه شنبه 27 اردیبهشت 1401 در 12:49 عصر

  4. #4
    کاربر دائمی آواتار plague
    تاریخ عضویت
    آبان 1388
    محل زندگی
    اهواز
    پست
    2,357

    نقل قول: عدم اجرای npm run dev

    ساخته شده بود از قبل یعنی چی ؟ دستور رو زدی ساختش یا وقتی پروژه رو گرفتی بودش توش ؟
    چون این کتابخونه ها ممکنه بسته به سیستم عامل یا عوامل مختلف نیاز باشه ورژن های متفاوتی نصب بشه روی کامپیوتر های مختلف
    پس باید خودتون دستور npm install رو بزنید و دانلود کنیدشون روی کامپیوتری که میخاید اجرا بشه


    اررور که میده معمولا خطوط اولش یا آخرش رو بخونید میتونید متوجه مشکل بشید
    برای شما مشخصا داره میگه


    'cross-env' is not recognized as an internal or external command,
    این یه پکیج هستش که توی فایل json هم نگاه کنی میبینیش باید نصب بشه ... حالا چرا نیست یا ممکنه فولدر Node_module رو با پروژت دانلود کرده باشی و با npmنصب نکرده باشی
    یا اینکه موقع نصب ارروری داده که شما متوجش نشدی

    فولدر node_modules , فایل package-lock.json رو حذف کن و دوباره دستور npm install رو بزن تانصب بشن همه بعد اجرا کن
    اگه باز همین اررور رو داد ممکنه مشکلی باشه در نصب این پکیج اونوقت سعی کن جدا نصبش کنی ببینی چی میگه
    npm install cross-env


    یه سری راهکار هم اینجا میتونی ببینی که ته همشون اینه که یا کلا فولدر رو پاک کن دوباره نصب کن همه رو یا اینکه این کتابخونه رو مجزا نصب کن

    https://stackoverflow.com/questions/45034581

قوانین ایجاد تاپیک در تالار

  • شما نمی توانید تاپیک جدید ایجاد کنید
  • شما نمی توانید به تاپیک ها پاسخ دهید
  • شما نمی توانید ضمیمه ارسال کنید
  • شما نمی توانید پاسخ هایتان را ویرایش کنید
  •